•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

[SOLVED] "AMD's Gaming Evolved Raptr App" cause for the error "VM_Create on UI failed" with JAMP and Steam

Posts
17
Likes
27
I stopped playing MB2 a few months ago because I was too lazy to find a solution for this. For the last couple of hours I've been trying to get MB2 to work and getting the error "VM_Create on UI failed" when joining a server, which seems to be a really common error. I have the Steam version of JKA. I even saw a few threads posted this month discussing it. After reading a bunch of these, I tried everything that was suggested but still didn't get it working. Puppytime and Ent suggested opening the game with the MBII Client engine from the launcher settings (which worked, but that means no Steam integration, and the HUD was stretched which was also addressed in one of the threads and didn't get solved), deleting or giving all permissions to the uix86.dll file, and giving the main folders and the game process (jamp.exe) write access and all permissions. None of these worked.

Someone suggested that it might be the AMD drivers having the problem, since sometimes the error came up and sometimes didn't, seemingly randomly. This error seems to be common with AMD users. I think I found the real problem, the "Raptr AMD Gaming Evolved" video capture software (it's essentially like Nvidia's Shadowplay). Even if you've turned the filming off, if the app is still running it clashes with MB2. You have to stop all Plays.tv and Raptr and Amd Gaming Evolved app processes from the task manager. It's really weird since it used to work fine with MB2, and I've filmed lots of stuff with it in the game.

Let me know if this works for you guys too.
 
Last edited:

Puppytine

Slayed dreamer
Posts
2,264
Likes
1,487
video capture software (it's essentially like Nvidia's Shadowplay). Even if you've turned the filming off, if the app is still running it clashes with MB2.
It was @thebiggerboat3 who first mentioned that game recording software can cause this issue.
I was pointing that out few times in my posts.
Someone suggested that it might be the AMD drivers having the problem
@Noob send me a pm, explaining that AMD drivers are preventing mb2 from working.

Anyhow, it's great that you actually found a source of that problem.

Also,
Puppytime
C'mon guys, what's keeping all of you from spelling my nick right? Huh? :D
 
Last edited:
Posts
17
Likes
27
It was @thebiggerboat3 who first mentioned that game recording software can cause this issue.

Guess I missed @thebiggerboat3 's comment, even though I read a number of the threads. Great that the source for the problem was found! I just quickly made this thread for visibility because many AMD users are apparently suffering from the problem. I would assume the problem is probably on AMD's end, as they've made major updates to the app pretty recently, but I don't think they would care to fix the problem, considering the Quake III engine used on JKA is so old. I think it was your comment @Noob that I read earlier which made me think it's the recording software's fault, thanks for that.

Thanks to Puttytine :) and ent!
 
Top