•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue FPS drops after updating driver

Posts
383
Reaction score
264
So, i downloaded Battlefront 2 beta and it gave me an error saying that i need to update my driver. And i went to updating it visiting nvidia site and updated my driver to 385.28. After that i go played beta (Which was pretty awesome) and then decided to play some mb2 afterwards. But i see that im getting lags and fps drops to 20-30. Is that some issue that most people have after updating their drivers? Any help would be cool.
 
Posts
33
Reaction score
38
I had to do the same thing but mine's fine, I am now getting the VM_Create on ui failed error again now though
 
Posts
3
Reaction score
0
Battlefront 2 is a raw, rushed game and at this time it is in beta phase. Problems to be expected, especially with weaker computers. Download AIDA64 or something and post your specification.
 
Posts
383
Reaction score
264
Yeah the annoying part is that almost everyone have PCs that can’t handle these graphics(except popular youtubers and rich boys with very expensive computers and videocards) But I somehow ‘fixed’ this by downloading previous versions of drivers. And now my battlefront looks crappy with those freezes and with the amount of stuff in it. Well... I guess my money went to shit but I’m going to try and get it to play at least on minimum settings. Really wanna see how heroes vs villains and campaign modes play like. At least mb2 stays here and it won’t go anywhere until new amazing Star Wars game comes out.(Not like it all happen in next 6 years with EA license on Star Wars games) Also the thing I liked in the beta are pretty much the graphics, the fighter battles and pretty much that’s all lol. I hate it when you need to skip that white-black screen when you die and always press ‘space’ to continue. Classes are fine though.
 
Posts
33
Reaction score
38
do you have Geforce Experience? That's how I updated mine and it's now version 385.69 not .28
 
Posts
383
Reaction score
264
I tried to update it to that ver. but it said my pc wasn’t compatible with it or something
 

Puppytine

Slayed dreamer
Posts
2,256
Reaction score
1,453
Any help would be cool.
You should do your own research.
Install old drivers (the one that gave you more FPS), see if something changed. Then update them again.
If you find relation between drivers' version and performance in Movie Battlers, that means NVIDIA screwed its drivers, not a lot we can do about.
You can stay on old drivers, or wait NVIDIA to release a new, fixed package. Try changing various video setting in MBII, maybe disabling some particular setting will bring your FPS to previous levels.
 

ent

Movie Battles II Team
Posts
847
Reaction score
371
Some drivers have hardcoded executable names, so "jamp.exe" prolly already has some "special" optimizations. Maybe you are using MBII engine? try to rename MBII engine to jamp.exe. Try to rename your engine to "customname.exe".
 

Defiant

Project Leader
Movie Battles II Team
Code Leader
Posts
796
Reaction score
1,112
Also make sure your default graphics hardware is still your nVidia chip. Doubly so if you play from a laptop.
 
Top