•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Launcher Can't update the launcher

Posts
52
Reaction score
66
I tried updating the launcher after the "new version available" popped-up, but it says there is a compatibility issue with my 64 bit system and that "16 bit application are not supported"

What am I supposed to do ?
 
Top