•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue Trying to run mb2 on linux

Posts
1
Reaction score
0
So i just installed jedi academy and after installed the openjk exe i installed mono and other things , tried to set_game mb2 thing and i just launches but when i join a server it says start the game via launcher but i cant run the launcher even if i do open with mono runtime terminal what can i do? Anyway i tried opening openjk and after going to mods and launching mb2 but it still says you need to open the game by launcher. Tried launching it from lutris but it just appears the mb2 logo and i doesnt get to lobby.
screenshot.jpg
 

Puppytine

Slayed dreamer
Posts
2,224
Reaction score
1,440
Forget about mono and MBII Launcher, they currently aren't going to work on Linux.
The fact you ever getting kicked with "... keep Launcher running" message means you're running Windows version of MBII via emulator.
Forget about any attempts of using any emulators like Wine, Proton, Cedega etc. They aren't going to work.
MBII Launcher has built-in anticheat, but that anticheat is only required for Windows, not Linux

There's native Linux version of MBII. You must use it. All required files (highly likely) are on your disk already.
Start file mbii.i386 with this command line parameters:
Code:
+set fs_game "MBII"
Do it either by typing command directly in terminal, or edit file play_mbii.sh (replace openjk.i386 with mbii.i386).

Be ready that you'll need to set up multiarch.
Absolutely majority of operation system these days are 64-bit, but Movie Battles is strictly 32-bit game.
64-bit Windows handle 32-bit programs out of box, completely automatically, but for Linux it's necessary to put some effort. Nothing really to hard, though.
During first launch the way I described, MBII will most likely crash, and will complain about missing dependencies.
Read crash message carefully and install all libraries Movie Battles will cry about.
Install ONLY 32-bit versions of those libraries using your package manager.
 
Last edited:
Top