•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue Stuck in game menu (stuttering)

Posts
2
Reaction score
0
Hi,

After searching for a similar issue on forums and not finding any, I gave up and decided to make a new thread.

Since ~3 months I have a problem that on older laptop I can't join any server. The reason is that whenever I launch MB through launcher (MBII Client), the game starts, but I'm stuck in the menu. The animation of MB2 logo is stuttering, after that I see the main menu, but I've got less than 1 FPS and the music/sound is stuttering as well. I am able to click buttons but it takes one minute to aim the servers list button and after that the list of them doesn't appear (I guess it's impossible to render the list when I have <1 FPS).
I reinstalled the game, updated the launcher, but still with no success.

Jedi Academy version: Steam
Computer specs:
upload_2019-6-22_11-57-35.png
Graphics card: NVIDIA Geforce 710M.

Windows states that 'the best drivers for your device are already installed'.

EDIT:
But the original Jedi Academy works ok.
I have also tried to run MB with different NVIDIA Control Panel settings. l have enforced using Geforce as a preferred graphics processor. Then the game launches with proper sound and without stuttering, but I cannot see the screen (it's white when launched in window mode and black/white in fullscreen mode). I can hear the menu effects though.

upload_2019-6-22_12-6-14.png
I'll be grateful for any help, cheers.
 
Last edited:

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
877
Reaction score
832
Original problem sounds like a lack of graphical acceleration. Make sure you don't have anything in GameData interfering (like custom OpenGL injectors used for graphics mods), otherwise it's down to making sure your GPU drivers are in working order.

The Windows statement is pretty useless as that really just means it's the latest Microsoft approved driver, which could be even just Microsoft's default built-in driver. Doesn't sound like it is in this case, but if you're using a laptop with integrated and discreet GPU switching then you can have weirdness if things aren't just so. Go to the manufacturer's website and see what they have.

If the original JKA is working fine, you could just use that (JAMP) instead of OpenJK. If you installed JKA to a Steam library on another drive (instead of the default location) then you will need to move it or the launcher won't be able to start it.
 
Posts
2
Reaction score
0
Thanks for advices. I checked that I really have the latest drivers both for Intel graphics and Geforce. Later I tried with moving JKA to an original Steam location and got 'Corrupt zone header' error. So I closed Steam, Launcher, tried to move JKA again from previous location to the Steam one, and it worked.

But after loading a map another error is thrown: "Sound/null has length 0". Some array isn't populated xD That's a weird one, and I haven't found it described in FAQ. I will keep you updated about any progress in this.

EDIT: found this Technical Issue - sound/null has length 0 but I already have 16bit 48kHz set.
I tried to do 'Repair Installation' and then launch the game, but the sound error occurred again. I think I will re-install JA and MBII and this time I will install it in Steam original folder.
 
Last edited:

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
877
Reaction score
832
"Corrupt zone header" means JASP (single player) was loading, so either the launcher was not flagged that you were using Steam in the settings, or something else went wrong (make sure the launcher has the correct path to GameData in its settings after moving too). Steam does not allow direct launching of multiplayer outside Steam itself, only single player, so the launcher temporarily swaps the executables on start when Steam integration is enabled.

Never heard of the sound error, but if the installation and everything else is working then I'd suspect corrupted assets. If the launcher repairs fine then it would be base JKA's assets at fault, which you can verify via Steam.
 
Top