•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue Slow load times

Posts
5
Reaction score
0
So my menu runs fine. As soon as I click play, and go to the server list, the game slows down considerably. Once I actually join a server, It will sit on the awaiting game state screen for minutes before actually going to the real loading screen, which can take up to 10 minutes or more to actually put me in a game. If I do manage to wait long enough to get into a game, it's choppy and the frame rate is low. Anyone know any fixes for this? I've already tried setting my network settings to the recommended. I don't particularly know what else to try.
 
Posts
5
Reaction score
0
Oh right that's important

2.8GHz Intel Core i7-7700HQ
GTX 1080
Intel HD Graphics 630
16GB DDR4
 

Fluffy |>

Internal Beta Team
EU Official Server Admin
Posts
171
Reaction score
109
you could be running the game off of your integrated graphics, not your dedicated gpu
 
Posts
5
Reaction score
0
How would I fix that? I apologise, I have no knowledge of PC gaming. I play two games on PC, MBII and Mount and Blade Warband.
 

KimmyMarin

US Official Server Admin
Posts
627
Reaction score
642
i for example have a freeze during the transition from a server to menu, which i didnt before this update.
also the long loading time happens to me as well but im certain im no using igpu in my case since i disabled it on bios.
 

Hessu

Internal Beta Team
Posts
392
Reaction score
603
The loading time from launcher to in game has increased quite a bit, game freezes when i go to menu from a server. Also if i try to join a server which is full, it goes to awaiting gamestate like normal but when i press esc to go back to menu, it freezes again. Not end of the world but really annoying in the long run
 

noel

Internal Beta Team
EU Official Server Admin
Posts
741
Reaction score
769
Doesn't seem right that you should be lagging that much with those specs. Not sure what to suggest, try updating your graphics drivers.

My laptop pales in comparison (1050 i5 8300h) but I can maintain 60fps despite spiking and I don't get 10 minute loading times.

Try running a benchmarking software or a more demanding/modern game, does your PC cope with them? Compare your FPS to benchmarks found online/on youtube.

EDIT: what about if you join lower population servers? Does your performance improve? Have you tried lowering graphics settings and advanced graphics settings?
 
Top