•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

[SOLVED] No servers on sever list

Posts
3
Reaction score
2
No servers are popping up for me on the server list. Help pls
Apparently there is a problem with the Master Server, or someone is DDOSing MBII (trying to crash the servers).

This is the second day and there has been no answer from the Dev Team.
 

MaceMadunusus

Level Designer
Movie Battles II Team
Posts
1,370
Reaction score
1,741
Yeah weve been having some DDOS attacks for over the past 24 or so hours. Been a little focused on dealing with it, and getting the update for today out. We did tell people via discord and were sitting on the official server monitoring and telling people all day.
 

Caelum

Donator
Posts
23
Reaction score
47
@Spaghetti @MaceMadunusus JKHub master server's been seeing a couple of attacks over the past days too, if you want, I can get you a JKA.io IP with DDoS protection to point the DNS record to and I can take care of everything else (for free), even as a temporary solution. Your call, just let me know if you need it.

EDIT: Hey look, the master server works.
 
Last edited:

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
891
Reaction score
851
@Spaghetti @MaceMadunusus JKHub master server's been seeing a couple of attacks over the past days too, if you want, I can get you a JKA.io IP with DDoS protection to point the DNS record to and I can take care of everything else (for free), even as a temporary solution. Your call, just let me know if you need it.
Much appreciated. Master should be working again with clients for now.
 

Puppytine

Slayed dreamer
Posts
2,121
Reaction score
1,341
Still/again "Down for everyone or just me"?
Make sure you actually have latest version of Movie Battles. It's was updated like a day ago.
Make sure your Jedi Academy is 1.01, not 1.00, or you're using MBII client.
 

Puppytine

Slayed dreamer
Posts
2,121
Reaction score
1,341
What port does the master server use? Still 29060 ?
Yes.

Try connecting manually, via console /connect command, different servers from this list, both EU and NA: Movie Battles II Server List
If you won't be able to connect, quote all the error you will get, fully and entirely.

Then, Start => Run => type:
Code:
cmd
=> Enter => type:
Code:
tracert master.moviebattles.org
And then:
Code:
ping master.moviebattles.org
Post a screenshot to this thread.
You can see an example of such screenshot below.

Then,
  1. Open a server list
  2. Open a console by pressing Shift + ~ (aka Shift + `)
  3. Make a screenshot, post it here.
    You can see an example of such screenshot below.



 
Last edited:
Posts
13
Reaction score
3
Manual connections would do (I guess I use Favourites list for now).

ping works fine 0% PL, however tracepath gives up after 62 hops (and would likely try for whatever else I raise the default of 30 to).
"End" of it is looking like this:
11: fra1-lmb1-vac1-a75-3.de.eu 22.096ms asymm 9
12: no reply

FWIW master2 fares better:
21: inap-b2.e5.router.dallas.nfoservers.com 142.221ms asymm 13
22: no reply


Console stays at Requesting servers from the master master.moviebattles.org ...

I noticed the globalservers command to request servers in the console (would that fill the UI list? I wonder what I would have to give it for protocol and maybe keywords, maybe master2 would work for me?

Duh wait it is apparently DNS as was suggested. It resolves to a different IP for me.

Thanks for your help!
 

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
891
Reaction score
851
Duh wait it is apparently DNS as was suggested. It resolves to a different IP for me.

Thanks for your help!
Yeah. It's funny because the screenshots Puppytine posted show his DNS is also caching things way too long with the old IP (the TTL is 5 minutes, so either the computer has a sticky cache or his DNS provider is being very lazy with its lookups).

You can clear the Windows cache with the command [ ipconfig /flushdns ]. If it's your DNS provider's fault, changing to a public, well maintained one like 8.8.8.8 or 1.1.1.1 should work.

The DDoSing has stopped for now so that master will work for the moment, but may not necessarily show many servers as everything restarted since the change will not report to it.
 

Puppytine

Slayed dreamer
Posts
2,121
Reaction score
1,341
Manual connections would do (I guess I use Favourites list for now).
So we can exclude the possibility that your installation is broken, outdated, or using Jedi Academy 1.00.
ping works fine 0% PL
First thing, I was asking about screenshots. Where they are?
Would be better if you posted screens instead of these brief quotes.
It's funny because the screenshots Puppytine posted show his DNS is also caching things
It's funny because my EXAMPLE screenshots were made literally years ago and were posted on these forums multiple times :\
You can see on the second screenshot the time and date when it was made :/
I'm posting the brand new screenshots at the bottom of this post.

Long story short, I suspect that @Pet a van was yeeted by master server's DDoS protection or direct IP ban.
I recommend @Pet a van to post his IP in this thread or PM it to Spaghetti or Defiant, so they check it for bans and DDoS defense malfunction.

As for me, a primary master server, master.moviebattles.org 54.37.94.200 (aka JKHub one), works just fine.
I see a bunch of servers in my list when I'm using it.
I also can ping it, but can't trace it.

When I switch to a secondary master, master2.moviebattles.org 66.151.244.207, there are only four servers displayed.
Both ping and trace work for this master server.

@Pet a van , try tracing master2.moviebattles.org once again.
Try opening this link: Portal - JKHub
Try manually connecting these servers: 54.37.94.205:29070, 54.37.94.193:29070, 54.37.94.210:29070, 54.37.94.229:29070.

You can make Movie Battles use secondary master server by following these steps:
  1. Open a file "C:\WINDOWS\system32\drivers\etc\HOSTS" with Notepad
  2. Add this line to the file:
    Code:
    66.151.244.207 master.moviebattles.org
  3. Save the file.





 
Last edited:

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
891
Reaction score
851
whargarbl
No, his IP isn't banned. The blocks that were happening before were very temporary anyway, and since the DDoSing stopped yesterday, have not been active. The issue for Pet a van (if there even still is one... unclear to me from the last post) isn't on the server side. If he still has a problem, clearing the Windows DNS cache, or more likely changing to a better DNS provider, will resolve it.
 

Puppytine

Slayed dreamer
Posts
2,121
Reaction score
1,341
isn't on the server side
Don't be so sure.
It may be not IP ban, but some of the attributes of IP packets that get filtered out by the firewall.

Back in the days, I didn't have an access to jkhub.org, and to their master server (which is now a Movie Battles master server) as well. The site just didn't get showed up in my browser. It was happening for months. Eventually, I contacted Caelum, and we spend some time testing things.
Turned out my ISP used some unusual network settings (not sure that I may reveal that specific setting in public) which were red flagged by jkhub's firewall.
After Caelum changed those settings, my access to jkhub was restored, same for the access to master.jkhub.org.
If he still has a problem, clearing the Windows DNS cache, or more likely changing to a better DNS provider, will resolve it.
Doubt.
It seems you're overestimate DNS a little bit. The only moment when DNS can make a difference is during very beginning of ping/tracert, when master.moviebattles.org is getting resolved.
But those quotes that Pet a van posted show that path of traffic was similar to that one on my screenshot. More over, if his DNS was cached and he was still using US master server, he was supposed to get those three servers in the list that I got when I manually switched to 66.151.244.207.
btw, that's why he really should posted actual screenshots, not just those little pieces of tracert output. It would show up to what IP master.moviebattles.org was resolved.

Executing tracert with an IP address as an argument, as well as modifying HOSTS file, would completely eliminate DNS factor.
 
Last edited:

Spaghetti

cable monster
R2D2
Movie Battles II Team Retired
Posts
891
Reaction score
851
I can't speak to jkhub's firewall settings, but I doubt there are a significant number of people with issues or there would be a lot more complaints. I wouldn't blame Caelum for being a little zealus with blocking anything that seems out of the ordinary. Regardless, our master server has been put back into operation.
 

Caelum

Donator
Posts
23
Reaction score
47
@Pet a van if you're still having issues (or anyone else is), please:
  • Restart both your modem/router and your computer (actually do both)
  • Wait up to a day
  • If it's still happening the next day, PM me your IP address and I'll see if your ISP is doing something criminally braindead to your traffic and adjust our firewall rules (or give you another solution, i.e. in case of bad port forwarding)
In 99% of cases, the first two steps will solve the issue though :)
 
Last edited:
Top