1.          Our team is looking for new blood.... could it be you?

          Help us move MBII forward with developing exciting new features!
          Support your favorite mod while gaining valuable experience!


          Join the MBII Team as a Beta Tester, Development Partner or Developer today! Click here for details.

Linux launcher not work if special signs in path

Discussion in 'Bug Tracker' started by Loaden, Apr 2, 2017.

  1. Loaden

    Loaden

    Posts:
    4
    Likes Received:
    1
    openJK: v1.0.1.0 linux-i386
    Movie Battles: 1.4.4
    System: Debian Jessie AMD64

    On game start click in launcher I have this issue if path to GameData contains special signs:
    I changed path from /JKA Kit (Jedi Academy, openJK, installed, mods+ing)/ to /JKA Kit/JKA/. The Launcher starts
    Movie Battles now.

    No executable rights at binary. Maybe it's caused by special signs while installation also.
    I did "chmod +x". Anything seems to be right.

    OT:
    Is libjpeg8 required to run Movie Battles or is in rd-vanilla-mbii_i386.so libjpeg62-turbo in use only?
    Is this the source for Movie Battles 2 (mbii.i386, renderer...)? I want to build AMD64 binaries for myself. I don't like multiarch.
     
  2. Puppytine

    Puppytine Slayed dreamer Technical & Gameplay Support

    Posts:
    1,127
    Likes Received:
    734
  3. Loaden

    Loaden

    Posts:
    4
    Likes Received:
    1
    On Linux systems it's a launcher issue only. Via "openjk.i386 +set fs_game "MBII"" the game works with special signs on directory.

    I used full command from launcher in shell. Option values for fs_cdpath, fs_basepath, fs_homepath need to be quoted.
    Should be fast & easy to fix in launcher. But low prio.
     
    Last edited: Apr 2, 2017
    LoU likes this.
  4. Puppytine

    Puppytine Slayed dreamer Technical & Gameplay Support

    Posts:
    1,127
    Likes Received:
    734
    Same behavior on Windows, please read thread I referred to more carefully.
     

Share This Page