1.     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Launcher Launcher on Linux

Discussion in 'Support' started by Loaden, Jul 6, 2018.

  1. Loaden

    Loaden

    Posts:
    11
    Likes Received:
    1
    System:
    • Linux 3.16.0-6-amd64 / Debian Jessie
    • AMD Phenom(tm) II X2 555 Processor
    • 4 GB Ram
    • GeForce GT 630

    If I try to start lauchner on Linux I get this error always:
    Code:
    GameDataMBII$ mono MBIILauncherLIN.exe   
    Unknown heap type: #Schema
    
    * Assertion at metadata.c:886, condition `index < meta->heap_strings.size' not met
    
    Stacktrace:
    
    
    Native stacktrace:
    
            mono() [0x4b5ca0]
            /lib/x86_64-linux-gnu/libpthread.so.0(+0xf890) [0x7f4aaa32d890]
            /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37) [0x7f4aa9fa8067]
            /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f4aa9fa9448]
            mono() [0x6406e5]
            mono() [0x640853]
            mono() [0x56a7cf]
            mono() [0x548b0d]
            mono() [0x549898]
            mono(mono_image_open_full+0xea) [0x549f2a]
            mono(mono_assembly_open_full+0x2be) [0x519f5e]
            mono() [0x5a766d]
            mono() [0x5a776b]
            mono() [0x5a7874]
            mono() [0x51b493]
            mono(mono_assembly_load_full+0x10) [0x51c0c0]
            mono(mono_assembly_load_reference+0x1e9) [0x51c809]
            mono(mono_class_from_typeref+0x434) [0x52a644]
            mono(mono_class_get_full+0x145) [0x52a7c5]
            mono() [0x56c098]
            mono() [0x529b6a]
            mono(mono_class_get_full+0xe2) [0x52a762]
            mono() [0x56d56a]
            mono(mono_metadata_parse_type_full+0x14) [0x56d714]
            mono() [0x526fa2]
            mono() [0x52b209]
            mono(mono_class_init+0x648) [0x523448]
            mono() [0x473713]
            mono() [0x422214]
            mono() [0x42584e]
            mono() [0x4267e1]
            mono(mono_runtime_invoke+0x3d) [0x5b8a8d]
            mono(mono_runtime_exec_main+0xbc) [0x5bb0fc]
            mono(mono_main+0x1253) [0x48b863]
            /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f4aa9f94b45]
            mono() [0x419fad]
    
    Debug info from gdb:
    
    [New LWP 3768]
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
    0x00007f4aaa32d489 in __libc_waitpid (pid=3769, stat_loc=0x7ffc8cad933c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    40      ../sysdeps/unix/sysv/linux/waitpid.c: Datei oder Verzeichnis nicht gefunden.
      Id   Target Id         Frame
      2    Thread 0x7f4aa7b87700 (LWP 3768) "mono" sem_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:85
    * 1    Thread 0x7f4aaae33780 (LWP 3767) "mono" 0x00007f4aaa32d489 in __libc_waitpid (pid=3769, stat_loc=0x7ffc8cad933c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    
    Thread 2 (Thread 0x7f4aa7b87700 (LWP 3768)):
    #0  sem_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:85
    #1  0x00000000006371d6 in mono_sem_wait ()
    #2  0x00000000005af5d4 in ?? ()
    #3  0x000000000059178b in ?? ()
    #4  0x000000000062ba1d in ?? ()
    #5  0x000000000063bd93 in ?? ()
    #6  0x00007f4aaa326064 in start_thread (arg=0x7f4aa7b87700) at pthread_create.c:309
    #7  0x00007f4aaa05b62d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
    
    Thread 1 (Thread 0x7f4aaae33780 (LWP 3767)):
    #0  0x00007f4aaa32d489 in __libc_waitpid (pid=3769, stat_loc=0x7ffc8cad933c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    #1  0x00000000004b5d3d in ?? ()
    #2  <signal handler called>
    #3  0x00007f4aa9fa8067 in __GI_raise ([email protected]=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
    #4  0x00007f4aa9fa9448 in __GI_abort () at abort.c:89
    #5  0x00000000006406e5 in ?? ()
    #6  0x0000000000640853 in ?? ()
    #7  0x000000000056a7cf in mono_metadata_string_heap ()
    #8  0x0000000000548b0d in ?? ()
    #9  0x0000000000549898 in ?? ()
    #10 0x0000000000549f2a in mono_image_open_full ()
    #11 0x0000000000519f5e in mono_assembly_open_full ()
    #12 0x00000000005a766d in ?? ()
    #13 0x00000000005a776b in ?? ()
    #14 0x00000000005a7874 in ?? ()
    #15 0x000000000051b493 in ?? ()
    #16 0x000000000051c0c0 in mono_assembly_load_full ()
    #17 0x000000000051c809 in mono_assembly_load_reference ()
    #18 0x000000000052a644 in mono_class_from_typeref ()
    #19 0x000000000052a7c5 in mono_class_get_full ()
    #20 0x000000000056c098 in ?? ()
    #21 0x0000000000529b6a in ?? ()
    #22 0x000000000052a762 in mono_class_get_full ()
    #23 0x000000000056d56a in ?? ()
    #24 0x000000000056d714 in mono_metadata_parse_type_full ()
    #25 0x0000000000526fa2 in ?? ()
    #26 0x000000000052b209 in ?? ()
    #27 0x0000000000523448 in mono_class_init ()
    #28 0x0000000000473713 in ?? ()
    #29 0x0000000000422214 in ?? ()
    #30 0x000000000042584e in ?? ()
    #31 0x00000000004267e1 in ?? ()
    #32 0x00000000005b8a8d in mono_runtime_invoke ()
    #33 0x00000000005bb0fc in mono_runtime_exec_main ()
    #34 0x000000000048b863 in mono_main ()
    #35 0x00007f4aa9f94b45 in __libc_start_main (main=0x419d10, argc=2, argv=0x7ffc8cadb888, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc8cadb878) at libc-start.c:287
    #36 0x0000000000419fad in ?? ()
    
    =================================================================
    Got a SIGABRT while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.
    =================================================================
    
    Abgebrochen
    
    Installed mono packages:
    Code:
    dpkg --get-selections | grep mono
    libmono-2.0-1                                   install
    libmono-2.0-dev                                 install
    libmono-accessibility2.0-cil                    install
    libmono-accessibility4.0-cil                    install
    libmono-addins-msbuild0.2-cil                   install
    libmono-addins0.2-cil                           install
    libmono-c5-1.1-cil                              install
    libmono-cairo2.0-cil                            install
    libmono-cairo4.0-cil                            install
    libmono-cecil-cil                               install
    libmono-cecil-private-cil                       install
    libmono-cil-dev                                 install
    libmono-codecontracts4.0-cil                    install
    libmono-compilerservices-symbolwriter4.0-cil    install
    libmono-corlib2.0-cil                           install
    libmono-corlib4.0-cil                           install
    libmono-corlib4.5-cil                           install
    libmono-cscompmgd8.0-cil                        install
    libmono-csharp4.0c-cil                          install
    libmono-custommarshalers4.0-cil                 install
    libmono-data-tds2.0-cil                         install
    libmono-data-tds4.0-cil                         install
    libmono-db2-1.0-cil                             install
    libmono-debugger-soft2.0a-cil                   install
    libmono-debugger-soft4.0a-cil                   install
    libmono-entityframework-sqlserver6.0-cil        install
    libmono-entityframework6.0-cil                  install
    libmono-http4.0-cil                             install
    libmono-i18n-cjk4.0-cil                         install
    libmono-i18n-mideast4.0-cil                     install
    libmono-i18n-other4.0-cil                       install
    libmono-i18n-rare4.0-cil                        install
    libmono-i18n-west2.0-cil                        install
    libmono-i18n-west4.0-cil                        install
    libmono-i18n2.0-cil                             install
    libmono-i18n4.0-all                             install
    libmono-i18n4.0-cil                             install
    libmono-ldap2.0-cil                             install
    libmono-ldap4.0-cil                             install
    libmono-management2.0-cil                       install
    libmono-management4.0-cil                       install
    libmono-messaging-rabbitmq2.0-cil               install
    libmono-messaging-rabbitmq4.0-cil               install
    libmono-messaging2.0-cil                        install
    libmono-messaging4.0-cil                        install
    libmono-microsoft-build-engine4.0-cil           install
    libmono-microsoft-build-framework4.0-cil        install
    libmono-microsoft-build-tasks-v4.0-4.0-cil      install
    libmono-microsoft-build-utilities-v4.0-4.0-cil  install
    libmono-microsoft-build2.0-cil                  install
    libmono-microsoft-build4.0-cil                  install
    libmono-microsoft-csharp4.0-cil                 install
    libmono-microsoft-visualc10.0-cil               install
    libmono-microsoft-web-infrastructure1.0-cil     install
    libmono-microsoft8.0-cil                        install
    libmono-npgsql2.0-cil                           install
    libmono-npgsql4.0-cil                           install
    libmono-opensystem-c4.0-cil                     install
    libmono-oracle2.0-cil                           install
    libmono-oracle4.0-cil                           install
    libmono-parallel4.0-cil                         install
    libmono-peapi2.0a-cil                           install
    libmono-peapi4.0a-cil                           install
    libmono-posix2.0-cil                            install
    libmono-posix4.0-cil                            install
    libmono-profiler                                install
    libmono-rabbitmq2.0-cil                         install
    libmono-rabbitmq4.0-cil                         install
    libmono-reflection-cil                          install
    libmono-relaxng2.0-cil                          install
    libmono-relaxng4.0-cil                          install
    libmono-security2.0-cil                         install
    libmono-security4.0-cil                         install
    libmono-sharpzip2.6-cil                         install
    libmono-sharpzip2.84-cil                        install
    libmono-sharpzip4.84-cil                        install
    libmono-simd2.0-cil                             install
    libmono-simd4.0-cil                             install
    libmono-sqlite2.0-cil                           install
    libmono-sqlite4.0-cil                           install
    libmono-system-componentmodel-composition4.0-cil        install
    libmono-system-componentmodel-dataannotations4.0-cil    install
    libmono-system-configuration-install4.0-cil     install
    libmono-system-configuration4.0-cil             install
    libmono-system-core4.0-cil                      install
    libmono-system-data-datasetextensions4.0-cil    install
    libmono-system-data-linq2.0-cil                 install
    libmono-system-data-linq4.0-cil                 install
    libmono-system-data-services-client4.0-cil      install
    libmono-system-data-services2.0-cil             install
    libmono-system-data-services4.0-cil             install
    libmono-system-data2.0-cil                      install
    libmono-system-data4.0-cil                      install
    libmono-system-design4.0-cil                    install
    libmono-system-drawing-design4.0-cil            install
    libmono-system-drawing4.0-cil                   install
    libmono-system-dynamic4.0-cil                   install
    libmono-system-enterpriseservices4.0-cil        install
    libmono-system-identitymodel-selectors4.0-cil   install
    libmono-system-identitymodel4.0-cil             install
    libmono-system-io-compression-filesystem4.0-cil install
    libmono-system-io-compression4.0-cil            install
    libmono-system-json-microsoft4.0-cil            install
    libmono-system-json2.0-cil                      install
    libmono-system-json4.0-cil                      install
    libmono-system-ldap-protocols4.0-cil            install
    libmono-system-ldap2.0-cil                      install
    libmono-system-ldap4.0-cil                      install
    libmono-system-management4.0-cil                install
    libmono-system-messaging2.0-cil                 install
    libmono-system-messaging4.0-cil                 install
    libmono-system-net-http-formatting4.0-cil       install
    libmono-system-net-http-webrequest4.0-cil       install
    libmono-system-net-http4.0-cil                  install
    libmono-system-net2.0-cil                       install
    libmono-system-net4.0-cil                       install
    libmono-system-numerics4.0-cil                  install
    libmono-system-reactive-core2.2-cil             install
    libmono-system-reactive-debugger2.2-cil         install
    libmono-system-reactive-experimental2.2-cil     install
    libmono-system-reactive-interfaces2.2-cil       install
    libmono-system-reactive-linq2.2-cil             install
    libmono-system-reactive-observable-aliases0.0-cil       install
    libmono-system-reactive-platformservices2.2-cil install
    libmono-system-reactive-providers2.2-cil        install
    libmono-system-reactive-runtime-remoting2.2-cil install
    libmono-system-reactive-windows-forms2.2-cil    install
    libmono-system-reactive-windows-threading2.2-cil        install
    libmono-system-runtime-caching4.0-cil           install
    libmono-system-runtime-durableinstancing4.0-cil install
    libmono-system-runtime-serialization-formatters-soap4.0-cil     install
    libmono-system-runtime-serialization4.0-cil     install
    libmono-system-runtime2.0-cil                   install
    libmono-system-runtime4.0-cil                   install
    libmono-system-security4.0-cil                  install
    libmono-system-servicemodel-activation4.0-cil   install
    libmono-system-servicemodel-discovery4.0-cil    install
    libmono-system-servicemodel-routing4.0-cil      install
    libmono-system-servicemodel-web4.0-cil          install
    libmono-system-servicemodel4.0a-cil             install
    libmono-system-serviceprocess4.0-cil            install
    libmono-system-threading-tasks-dataflow4.0-cil  install
    libmono-system-transactions4.0-cil              install
    libmono-system-web-abstractions4.0-cil          install
    libmono-system-web-applicationservices4.0-cil   install
    libmono-system-web-dynamicdata4.0-cil           install
    libmono-system-web-extensions-design4.0-cil     install
    libmono-system-web-extensions4.0-cil            install
    libmono-system-web-http-selfhost4.0-cil         install
    libmono-system-web-http-webhost4.0-cil          install
    libmono-system-web-http4.0-cil                  install
    libmono-system-web-mvc1.0-cil                   install
    libmono-system-web-mvc2.0-cil                   install
    libmono-system-web-mvc3.0-cil                   install
    libmono-system-web-razor2.0-cil                 install
    libmono-system-web-routing4.0-cil               install
    libmono-system-web-services4.0-cil              install
    libmono-system-web-webpages-deployment2.0-cil   install
    libmono-system-web-webpages-razor2.0-cil        install
    libmono-system-web-webpages2.0-cil              install
    libmono-system-web2.0-cil                       install
    libmono-system-web4.0-cil                       install
    libmono-system-windows-forms-datavisualization4.0a-cil  install
    libmono-system-windows-forms4.0-cil             install
    libmono-system-windows4.0-cil                   install
    libmono-system-xaml4.0-cil                      install
    libmono-system-xml-linq4.0-cil                  install
    libmono-system-xml-serialization4.0-cil         install
    libmono-system-xml4.0-cil                       install
    libmono-system2.0-cil                           install
    libmono-system4.0-cil                           install
    libmono-tasklets2.0-cil                         install
    libmono-tasklets4.0-cil                         install
    libmono-wcf3.0a-cil                             install
    libmono-web4.0-cil                              install
    libmono-webbrowser2.0-cil                       install
    libmono-webbrowser4.0-cil                       install
    libmono-webmatrix-data4.0-cil                   install
    libmono-windowsbase3.0-cil                      install
    libmono-windowsbase4.0-cil                      install
    libmono-winforms2.0-cil                         install
    libmono-xbuild-tasks2.0-cil                     install
    libmono-xbuild-tasks4.0-cil                     install
    libmono2.0-cil                                  install
    libmonoboehm-2.0-1                              install
    libmonoboehm-2.0-dev                            install
    libmonogame-cil                                 install
    libmonosgen-2.0-1                               install
    mono-2.0-gac                                    install
    mono-2.0-service                                install
    mono-4.0-gac                                    install
    mono-4.0-service                                install
    mono-complete                                   install
    mono-csharp-shell                               install
    mono-devel                                      install
    mono-gac                                        install
    mono-jay                                        install
    mono-mcs                                        install
    mono-runtime                                    install
    mono-runtime-common                             install
    mono-runtime-sgen                               install
    mono-tools-gui                                  install
    mono-utils                                      install
    mono-xbuild                                     install
    monodoc-base                                    install
    monodoc-browser                                 install
    monodoc-manual                                  install
    
     
  2. Puppytine

    Puppytine Slayed dreamer

    Posts:
    1,980
    Likes Received:
    1,275
    I guess it's a bug in the Launcher.
    Until devs fix it, you should use manual install: Download
    Luckily anti-cheating system isn't applied on Linux, so Launcher isn't obligatory for you.
     
  3. Defiant

    Defiant Project Leader Movie Battles II Team Code Leader

    Posts:
    562
    Likes Received:
    664
    What command line are you using?
     
  4. Loaden

    Loaden

    Posts:
    11
    Likes Received:
    1
    Command line:
    Code:
    $ bash --version
    GNU bash, Version 4.3.30(1)-release (x86_64-pc-linux-gnu)
    
     
    Last edited: Jul 10, 2018
  5. Defiant

    Defiant Project Leader Movie Battles II Team Code Leader

    Posts:
    562
    Likes Received:
    664
    ...For mono
     
  6. Loaden

    Loaden

    Posts:
    11
    Likes Received:
    1
    Which command line do you mean? All mono packages including start up command are in the first post. Please specify exactly what information you need.
     
  7. Spaghetti

    Spaghetti overcooked pasta Movie Battles II Team Retired

    Posts:
    777
    Likes Received:
    744
    Can confirm this issue on a fresh install of Debian Jessie.

    EDIT: Same issue on Stretch. A secondary problem there is the old launcher version (offered in Downloads) crashes on trying to auto update. I had to manually get the latest version to confirm the original crash.

    Code:
    [email protected]:~/Downloads$ mono MBIILauncherLIN.exe
    WARNING: The runtime version supported by this application is unavailable.
    Using default runtime: v4.0.30319
    Unknown heap type: #Schema
    
    * Assertion at metadata.c:950, condition `index < meta->heap_strings.size' not met
    
    Stacktrace:
    
    
    Native stacktrace:
    
        mono(+0xc8d94) [0x56553491dd94]
        /lib/x86_64-linux-gnu/libpthread.so.0(+0x110c0) [0x7fbe5fd3c0c0]
        /lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcf) [0x7fbe5f7a7fff]
        /lib/x86_64-linux-gnu/libc.so.6(abort+0x16a) [0x7fbe5f7a942a]
        mono(+0x289fe9) [0x565534adefe9]
        mono(+0x28a27c) [0x565534adf27c]
        mono(+0x28a413) [0x565534adf413]
        mono(+0x194b05) [0x5655349e9b05]
        mono(+0x173c05) [0x5655349c8c05]
        mono(+0x174918) [0x5655349c9918]
        mono(mono_image_open_full+0xdd) [0x5655349ca0fd]
        mono(mono_assembly_open_full+0x316) [0x565534994bc6]
        mono(+0x1ddd9f) [0x565534a32d9f]
        mono(+0x1ddeac) [0x565534a32eac]
        mono(+0x1df175) [0x565534a34175]
        mono(+0x14119b) [0x56553499619b]
        mono(+0x141d9b) [0x565534996d9b]
        mono(mono_assembly_load_reference+0x11d) [0x56553499741d]
        mono(mono_class_from_typeref_checked+0x36e) [0x5655349a8b6e]
        mono(+0x15219e) [0x5655349a719e]
        mono(+0x15318a) [0x5655349a818a]
        mono(+0x1968dc) [0x5655349eb8dc]
        mono(+0x1528b2) [0x5655349a78b2]
        mono(+0x15217e) [0x5655349a717e]
        mono(+0x198063) [0x5655349ed063]
        mono(+0x14d41d) [0x5655349a241d]
        mono(+0x150367) [0x5655349a5367]
        mono(mono_class_init+0x3e6) [0x56553499e856]
        mono(+0x6caf7) [0x5655348c1af7]
        mono(+0x12ca51) [0x565534981a51]
        mono(+0x12e7b9) [0x5655349837b9]
        mono(+0x3c9f0) [0x5655348919f0]
        mono(+0x3d6b0) [0x5655348926b0]
        mono(+0x1eb81e) [0x565534a4081e]
        mono(mono_runtime_exec_main+0x2cd) [0x565534a4a6cd]
        mono(mono_runtime_run_main+0x19e) [0x565534a4a94e]
        mono(mono_jit_exec+0x75) [0x5655348ed9e5]
        mono(mono_main+0x132e) [0x5655348ef1ae]
        mono(+0x38ab6) [0x56553488dab6]
        /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7fbe5f7952e1]
        mono(_start+0x2a) [0x56553488de8a]
    
    Debug info from gdb:
    
    
    =================================================================
    Got a SIGABRT while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.
    =================================================================
    
     
    Last edited: Jul 14, 2018
  8. Loaden

    Loaden

    Posts:
    11
    Likes Received:
    1
    Debian Strech maybe crashes because of the not supported / too old mono runtime version. I'm not sure if this is the the same bug like in Jessie.

    For all Linuxer:

    For update from 1.4.9 to 1.5 you can't use torrent download with specified path to MBII to merge old and new files. Torrent link isn't up to date at the moment. You need to use this link for update.

    If you want to use launcher on Linux you can use wine / PlayOnLinux with .NET to get it running.

    Comfortable startup is possible without wine if you use the following command:
    Code:
    ./mbii.i386 +set sv_master1 master.moviebattles.org +set cl_motdServer1 master.moviebattles.org +set fs_basepath "<PATH TO JKA>/GameData/" +set fs_cdpath "<PATH TO JKA>/GameData/" +set fs_homepath "<PATH TO JKA>/GameData/" +set fs_game MBII
    
    EDIT: removed stupid suspicions
     
    Last edited: Jul 16, 2018

Share This Page