I'm new to this Mod and need help

Discussion in 'Bug Tracker' started by Agent Nibbles, Dec 19, 2018.

  1. Agent Nibbles

    Agent Nibbles

    Posts:
    5
    Likes Received:
    2
    So i just installed this mod yesterday, I bought Jedi Academy for myself and for 3 friends so we could have fun on this mod I keep hearing is better than EA's Battlefront 2. We all successfully downloaded it with no problem and it took about 5 minutes for each one of us to find put the file in the Jedi Academy data. We booted it up and right off the start we're experiencing a lot of bugs. When we click on guide or setting, tutorials all the writing is blank. There's a page that gives us a rundown of all the classes but it's blank and 1 of my friends is able to see what it says and the rest of us can't. We ignored it and went in to join servers. Most of the time we keep getting disconnected even servers with good ping. Se load in, select a player model and before anything happens disconnected right away. The few servers that we do join people are T posing and animations seem to be very broken making it hard to tell when they're gonna attack, crouch, force pushed to the ground, rolling, etc. The video that introduced us to the mod was by Saintmillion on YouTube, from what he showed us it works and plays just fine so are we missing any extra steps to the installation? We were on it for 4 hours yesterday just yelling and getting mad that we can't even do anything but sit in the main menu. We need help.
     
  2. SeV

    SeV EU Official Server Admin Internal Beta Team

    Posts:
    921
    Likes Received:
    1,299
    Put the launcher in gamedata, run it, install game, repair, check files and make sure steam integration is ticked. Keep the launcher running in the background and join a server. It should work just fine like that and if not you need to be more specific about what you're doing and what the problems are. Hopefully you're launching MBII from the launcher and not from JAMP -> mods.
     
    Agent Nibbles and Puppytine like this.
  3. Agent Nibbles

    Agent Nibbles

    Posts:
    5
    Likes Received:
    2
    I'll try that right now and see if there's anything specific that comes up. I appreciate the help, Thank you so much
     
  4. SeV

    SeV EU Official Server Admin Internal Beta Team

    Posts:
    921
    Likes Received:
    1,299
    No problem. I hope you can get it working, it's great fun esp with mates.
     
  5. Agent Nibbles

    Agent Nibbles

    Posts:
    5
    Likes Received:
    2
    I did all before but I haven't integrated it with steam. I just did that now and checked the files. Now in the setting do I leave the Engine on Jamp or do i change that?
     
  6. Agent Nibbles

    Agent Nibbles

    Posts:
    5
    Likes Received:
    2
    So I got the animations, the texts, and everything running perfectly. There's just one last problem when joining servers. We still keep getting the error. It read "Error: Server Disconnect: quit: Please start the game via launcher and keep running it!". We have the launcher running in the background and keep getting this error.
     
  7. SeV

    SeV EU Official Server Admin Internal Beta Team

    Posts:
    921
    Likes Received:
    1,299
    Whatever works. You should be able to do either and it's mostly preference. I'd try engine first and do jamp if all else fails.

    Edit: I don't know about the launcher thing. That seems weird. Maybe an issue with Antivirus? Is the launcher really running? I don't know much about this specifically, so you could wait for a launcher expert or join discord and ask around.
     
  8. Agent Nibbles

    Agent Nibbles

    Posts:
    5
    Likes Received:
    2
    I'll join the discord. Thank you so much for the help. Me and my friends are gonna try this again on Friday.
     
    Deep and SeV like this.

Share This Page