•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue How to Disable Fullscreen

Posts
2
Likes
0
Movie Battles 2 started to crash when i made resolution 1600x ... in fulscreen. I'm sure the problem will be solved if i can disable fullscreen. I was be able to make any resolution in windowed mode. I can't get in the game, when i click to "play", it launches but in blackscreen and shutting itself before i even see something or control. Is there any way to disable fullscreen out of game maybe in files or something. I searched for setting files to change but could not found. Please help me, i don't want to uninstall and reinstall.
 

Puppytine

Slayed dreamer
Posts
2,264
Likes
1,486
Is there any way to disable fullscreen out of game maybe in files or something.
Yes there is.
The name of the file depends on what engine you do use:

JAMP:
Jedi Academy\GameData\MBII\jampconfig.cfg

MBII Client:
Jedi Academy\GameData\MBII\openjk.cfg
My Documents\My Games\OpenJK\MBII\openjk.cfg

The line you're searching for is
Code:
seta r_fullscreen "1"
To enable windowed mode, edit it to:
Code:
seta r_fullscreen "0"
But this is a bit weird that you get crashes depending on what your resolution is.
You may want trying some additional troubleshooting steps.

First, try switching engines, from jamp to MBII Client, or in reverse:
MBII Launcher => Settings => uncheck "Steam integration" (skip if there's no such checkbox) => Engine => MBII Client => Play.
If you already use MBII Client, select jamp instead.

Second, please make sure you actually do set the resolution that actually does match an exact physical resolution of your monitor.
For example, if your monitor is 2560 x 1600, but you are trying to set up 2650 x 1600, you may get in trouble.
Same if you mix up height and width, setting up 1600 x 2560.
Double, triple check the actual values you're entering.
 
Last edited:
Posts
10
Likes
2
Yes there is.
The name of the file depends on what engine you do use:

JAMP:
Jedi Academy\GameData\MBII\jampconfig.cfg

MBII Client:
Jedi Academy\GameData\MBII\openjk.cfg
My Documents\My Games\OpenJK\MBII\openjk.cfg

The line you're searching for is
Code:
seta r_fullscreen "1"
To enable windowed mode, edit it to:
Code:
seta r_fullscreen "0"
But this is a bit weird that you get crashes depending on what your resolution is.
You may want trying some additional troubleshooting steps.

First, try switching engines, from jamp to MBII Client, or in reverse:
MBII Launcher => Settings => uncheck "Steam integration" (skip if there's no such checkbox) => Engine => MBII Client => Play.
If you already use MBII Client, select jamp instead.

Second, please make sure you actually do set the resolution that actually does match an exact physical resolution of your monitor.
For example, if your monitor is 2560 x 1600, but you are trying to set up 2650 x 1600, you may get in trouble.
Same if you mix up height and width, setting up 1600 x 2560.
Double, triple check the actual values you're entering.
So, I'm trying to force the game to go into windowed mode and nothing is working anymore, it is the only way OBS can record it, everything else has failed. Idk what to do I just want to record Movie Battles 2...
 
Top