1.     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

[SOLVED] Getting the Mod on Mac

Discussion in 'Support' started by Parker101200, Nov 28, 2015.

Thread Status:
Not open for further replies.
  1. Parker101200

    Parker101200

    Posts:
    91
    Likes Received:
    4
    Mac users! I finally got the mod to work! Follow these steps to get it working.

    Download the game on Steam.

    Download the Modification
    Star Wars: Movie Battles II v1.3.1 download

    Open Steam Folder.
    > Right click on game Jedi Knight: Jedi Academy
    > Properties
    > Local Files
    > Browse Local Files

    You will find the folder " Star Wars Jedi Knight: Jedi Academy "
    > Right click
    > Show package contents

    You will see folder
    " Contents " and " installscript_osx.vdf "
    > click and open Contents
    > Move ALL FILES from the newly downloaded Modification folder ( mb2-v1-3 ) into " Contents " ( Equivalent of Game Data in MAC )

    Go to folder " MB II "
    Copy " z_MB_BaseAssets.pk3 " from MB II folder and paste into Base folder ( This will remove any bugs with models )
    Remove the remaining " z_MB_BaseAssets.pk3 " in folder MB II

    Download the version 1.3.1 to 1.3.2 Upgrade
    http://www.moviebattles.org/download/servers/V1.3.1_V1.3.2_Upgrade.zip
    > Unzip the file and then take all the files from inside the MBII folder (the one you just downloaded) and move them to the MBII inside your "contents" folder inside of Jedi Academy.

    Download Jedi Academy MP Launcher
    http://jkhub.org/files/file/1019-jedi-academy-mp-launcher-for-os-x/
    > Open folder
    > Move "JKJALaunch.app" into Jedi Academy folder ( Will appear beside " Star Wars Jedi Knight: Jedi Academy " )
    > Double click " JKJALaunch.app "
    > Under command line options type in "+set fs_game MBII" (without quotes). If you've tried this many times and already have the JKJA downloader installed, hold shift while opening the JKJA launcher to bring up the settings in order to get to the comman line options.
    > Check the "Save these settings" box and continue
    > Launch Multiplayer!

    Let me know if you have questions.
     
    Last edited: Nov 29, 2015
    matick_o likes this.
  2. rerstheguy

    rerstheguy

    Posts:
    2
    Likes Received:
    0
    I have been trying to get the mod working on my mac for 3 days now and I just can't get it to work. I seem to have properly placed all of the required zip files into my Jedi Academy folder, and I followed all of the steps listed here, but for some reason the MBII mod isn't showing up for me. I have tried the "+set fs_game MBII" command in both the JKJALaunch.app and in steam, but the game always just launches to the regular, un-modded multiplayer. I also have tried to go into the games settings and attempt to load the MBII mod, but no mods appear within my settings at all. Any ideas?
     
  3. rerstheguy

    rerstheguy

    Posts:
    2
    Likes Received:
    0
    Update: I've gotten the mod to actually launch and I can see the list of servers, but every time I attempt to join one I am prompted with a message that says I am missing files.
     
  4. Supa

    Supa The Serial Stacker Movie Battles II Team Retired

    Posts:
    925
    Likes Received:
    345
    Download the official launcher, download Mono, and follow the directions on that page. They seem simple enough, and will allow you to run the launcher, which will download the entire contents of the mod and keep them up-to-date, in addition to allowing you to launch the game via the launcher.
     
  5. Parker101200

    Parker101200

    Posts:
    91
    Likes Received:
    4
    I would get rid of all the files you have for JKJA. In steam, delete your local content for JKJA. Then, in finder, go to macintosh (or whatever your main drive is called), users, "your username", library. Under library go to application support, then go to Jedi Academy first and delete the whole folder. Then, while still under Library, go to steam, steamapps, common, and then delete jedi academy if its there. If not your ready to go. After you've nuked everything, start over and follow these steps exactly.
     
  6. Olirim

    Olirim

    Posts:
    4
    Likes Received:
    0
    I followed all the instructions, but whenever I try to join a server, it shows an error message saying something about missing files in my MBII folder making it impossible to join any server. Furthermore when i open JKJALaunch It only shows me the configuration menu which I cant change because the ok button is greyed out ..

    How can I fix this ?
     
  7. Olirim

    Olirim

    Posts:
    4
    Likes Received:
    0
    OK i fixed it myself, for everyone experiencing the same issue, you need to locate the Star Wars Jedi Knight: Jedi Academy.app correctly it didnt work for me at first because my mac book wouldnt show the library folder.. once I made it visible it worked.
     
  8. Parker101200

    Parker101200

    Posts:
    91
    Likes Received:
    4
    Yup, exactly what I was going to tell you. You have to have the right JKJA file selected to launch, otherwise the JKJA launcher wont let you do anything. Glad you figured it out!
     
  9. TheWelshWizard

    TheWelshWizard

    Posts:
    16
    Likes Received:
    0
    I am having the same problem. How did you get the mod to work in the end?
     
  10. kikili

    kikili Movie Battles II Team

    Posts:
    148
    Likes Received:
    45
    Sorry to com here a bit late but if you use Steam version the all MBII folder must be located in :
    ~/Library/Application Support/Jedi Academy
    If you are using regular CD version :
    ~/Library/Application Support/Jedi Academy MP
    If you are using OpenJK :
    ~/Library/Application Support/OpenJK

    Then launch it through JKJALaunch.app adding +set fs_game MBII in the setup (hold shift key the first time you use it)
    and
    THAT'S IT !!!
    Don't need to copy any file elsewhere.

    Normally the launcher should help you as well to do that. I place here a version if you didn't get it (prior install mono framework).
     
Thread Status:
Not open for further replies.

Share This Page