•     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

[SOLVED] Getting MB2 to work on a MacBook Pro Retina

Status
Not open for further replies.
Posts
5
Reaction score
1
Hey folks, having a bit of trouble getting the mod to work...

I have a mid 2012 MacBook Pro Retina running OS X El Capitan. I bought JK3 off of steam and that works fine. I put the mod into the folder according to the read-me, and went straight to multiplayer normally since I can't open the .bat file on my mac. I tried to load the mod in game, and here's where I ran into trouble.

The MB2 logo pops up as if it's booting up the mod, but then it just fails and goes back to regular MP. I tried using the JKJA launch by redsaurus but it never recognizes the app even if I manually type in the destination, and adding the +set fs_game "MBII" through steam and running JK3 but it doesn't change anything.

I saw in another thread that I was supposed to download mono? I have no idea what that is. I downloaded it anyway and it didn't make any difference / still can't open the .bat file.
 

Spaghetti

cable monster
R2D2
Movie Battles II Team
Posts
1,000
Reaction score
958
Getting the launcher to work with a Mac is an arcane art that unfortunately few understand. The install instructions were lost with the old forums. Another thing that needs working on.
 
Posts
5
Reaction score
1
Sounds like you are missing a jamp config file. I would suggest reinstalling JK and install using the new launcher update.
https://community.moviebattles.org/threads/launcher-fix-released

Oh hey! Seems like all I had to do was reinstall JK3. Well I feel like a doofus.

Now MB2 starts which is great. However, when I try to join a server, it says that MB2_um_assets3.pk3 (or something along those lines) is missing. Does that mean I installed MB2 wrong somehow? Or is there a recent patch?

Thanks for the help guys!
 

Spaghetti

cable monster
R2D2
Movie Battles II Team
Posts
1,000
Reaction score
958
Do an integrity check on start, the file might be corrupted.
 
Posts
5
Reaction score
1
It's not that the files are corrupt, it's that they weren't included in the download and I don't know what they are...

MB2_um_assets2.pk3? What's this from?
 
Posts
5
Reaction score
1
That's an issue with the steam version of mac Jedi Academy - if you don't have all the files that a server has you can't join it. JKJALaunch has a workaround for that - the latest version is available here: http://jkhub.org/files/file/1019-jedi-academy-mp-launcher-for-os-x/ What was going wrong before with JKJALaunch? Which path are you putting in?
I'm not sure if it's an error with my computer or not, but I can't see all the files in my computer when I try to navigate through the choose option in JKJALauncher. It only wants to show me files from the last 30 days, and there's no option that I can find to change that. I've tried searching for the files with no luck.

So I've tried to do it manually.

I've stuck it in literally every folder possible. I've tried it in SteamApps/common/Jedi Academy/Star Wars Jedi Knight: Jedi Academy.app, I've tried renaming that to Jedi Academy MP according to the launcher, I've opened that app to show the contents, so users/codydales/Library/Application Support/Steam/SteamApps/common/Jedi Academy/Jedi Academy MP.app/Contents/Star Wars Jedi Knight: Jedi Academy.app. There are two apps in there, one for single player and one for multiplayer. I've tried removing the single player app so it will only be able to link to MP, I've tried renaming the MP app (though I can't rename it to Jedi Academy MP), and I've tried opening up that as well to get to the unix executable file for MP and placing JKJALaunch beside it.

Nothing has worked so far. It only tells me that the current version selected is unsupported and the "okay" option is greyed out.

Edit: Made sure to update the launcher, still no luck.
 
Last edited:

redsaurus

Movie Battles II Team
Posts
15
Reaction score
16
If you try SteamApps/common/Jedi Academy/SWJKJA.app that *should* work. No idea why it's only showing files from the last 30 days, I better check if there are any issues with that on El Capitan.
 
Posts
5
Reaction score
1
If you try SteamApps/common/Jedi Academy/SWJKJA.app that *should* work. No idea why it's only showing files from the last 30 days, I better check if there are any issues with that on El Capitan.
All right! So part of the problem was that the package is called Star Wars Jedi Knight: Jedi Academy, but the file itself is actually SWJKJA.app like you said. I changed that and it's working. It booted me directly into MBII, which is awesome.

I turned off auto downloads now that I have your launcher working, and everything seems to be fine! I'll post back if not, but I think that did it! Thanks a ton, dude!

 
Status
Not open for further replies.
Top