Capture with jaMME in MBII 1.4.5 (with dropped editing support)

ent

Movie Battles II Team
Posts
866
Reaction score
375
Hello.

Since MBII 1.4.5 editing MBII demos with jaMME is not longer supported because that part of code used in MBII violated GPL and had to be removed.
But capturing with jaMME is still possible.

For though lucky ones who still have mmeMBII/cgamex86.dll of MBII 1.4.4(.1) or earlier, you are still able to use jaMME fully without restrictions but you won't be able to see new MBII v1.4.5 features in new demos.

For the rest.
1. Download jaMME: jaMME - JKHub
2. Extract to GameData.
3. You will have to edit start_jaMME_MBII.cmd to have the following:
Code:
@echo off
start jamme +set fs_game MBII
4. Give jamme.exe admin rights and launch start_jaMME_MBII.cmd.
5. Assuming you have your demos saved in MBII/demos/, just navigate in main menu to Play -> Play demo, and select any to play it back.


With the above setup demos from previous versions won't work.
Just use jaMME as before but change the demo player to the regular one with mme_demoConvert.

1. Select Demo Editor engine in MBII Launcher settings.
2. It will ask you to download the mod if you don't have it.
3. Copy cgamex86.dll from MBII/MBII.pk3 to mmeMBII/ and uix86.dll from mme/ to mmeMBII/
This step has to be done automatically by the launcher but just in case.
4. Put your demos into mmeMBII/demos/
5. Start jaMME (Demo Editor) as before via the launcher or via original version of start_jaMME_MBII.cmd:
Code:
@echo off
start jamme +set fs_game mmeMBII +set fs_extraGames "mme MBII"
6. Set mme_demoConvert to 0 to use the regular demo player in jaMME.
If it stays 1 then your demo will be loaded but not played back (staying on the first frame).
7. In main menu: Demos -> select your demo -> Play demo.
6. To start capturing do "cl_avidemo <FPS>" where FPS is the output video FPS.
For example: "cl_avidemo 60" will start capturing demo and make a 60fps video.
7. To stop capturing do "cl_avidemo 0".
If you are capturing with pipeline feature or AVI, you can do "capturestop" (and "capturestopstereo" for 3D capture) to be able to play just captured video without stopping the demo. Or just stop the demo and it will finish capturing work automatically.
8. Find your video in MBII/capture/.

Cvars to make things better:
mme_screenShotFormat <pipe, avi, png, jpg, tga>. I highly recommend to use pipe (see below how to set up).
mme_saveWav 2 to capture audio into pipeline file or AVI; 1 to capture audio in a separate file.
mme_blurFrames <0-256> but limited to FPS*mme_blurFrames <= 1000.
For example: to capture with 60fps you may set mme_blurFrames to 16 max because 60*16=960 and it's <= 1000.
mme_demoFileName <name> will specify the output name.
mme_pipeCommand "ffmpeg -f avi -i - -threads 0 -preset ultrafast -y -pix_fmt yuv444p -crf 23 %o.mp4 2> ffmpeglog.txt" - default.
Modify -crf value for quality (lower value - higher quality, bigger filesize),
-preset for capture speed (veryslow - to reduce filesize in 2 times),
-pix_fmt to change pixel format (yuv444p - full range, yuv420p - most compatible format with all players);
do not modify the rest in that cvar.
com_affinity 0 for pipeline, 1 for all the rest capturing (requires game restart).
Reference: Encode/H.264 – FFmpeg

Set up pipeline feature:
1. Download FFmpeg: FFmpeg
2. Put ffmpeg.exe to GameData.
3. Start the game.
4. Set mme_screenShotFormat to pipe.
5. Start any demo and try to capture as described above.
6. If something fails, find ffmpeglog.txt in GameData.

Now go make cool videos.

P.S.: please, tell if it works for you.
 
Last edited:

ent

Movie Battles II Team
Posts
866
Reaction score
375
It's a 1.4.4 demo. I can't play it in normal MB2 either says client version is 1.4.5 and server is 1.4.4 when I try to play it.
When you are loading a demo, does it print on screen "YES MME IS LOADING"?
 

ent

Movie Battles II Team
Posts
866
Reaction score
375
Tested your demo. It works fine on my side. It has a lag at the beginning though.
Try to check MBII integrity?

- - - Updated - - -

IMPORTANT!!
I've updated the first post.
Start jaMME as before but with the regular demo player now.
 
Last edited by a moderator:
Posts
549
Reaction score
482
Tested your demo. It works fine on my side. It has a lag at the beginning though.
Try to check MBII integrity?
Checked integrity, all fine. I found out what's the problem, cgame is no longer a .dll file, it's now an .so file.
 

ent

Movie Battles II Team
Posts
866
Reaction score
375
Checked integrity, all fine. I found out what's the problem, cgame is no longer a .dll file, it's now an .so file.
It's a pretty funny nonsense.
cgame is a .dll on Windows. It gets executed because you get the error.
.so is a linux dynamic library, it's unused.
I guess you are just unlucky, the error is unrelated to mme.
So, the patch is awesome now? :p
What? How is it related to this thread?
 
Posts
549
Reaction score
482
??
Try the updated way to start the mod (the original one with the regular demo player).
I tried that, but because my cgame turned into a Linux .so file, it says "VM create on cgame failed". This must be some bug with the launcher, it downloaded the Linux version and replaced my files with that. But somehow, my game still works...
 
Top