1.     Please make sure you check the Support FAQ and relevant Guides before you create a new thread in this section!

Technical Issue Awaiting gamestate...

Discussion in 'Support' started by Miister_Side, Jun 29, 2018.

  1. Miister_Side

    Miister_Side

    Posts:
    18
    Likes Received:
    7
    Well my problem is that I can enter and play in some servers, and in other servers I can't. Yesterday I was playing without any kind of problem in the
    server that I usually play (Initium Novum duel) but today when I was trying to join the server, this message appeared.

    [​IMG]
    Basically, when this message appears it should start joining the server. But in my case it doesn't, and the screen stays that way without being able to do anything, only the music of mb2 is heard in the background and if I press Esc it takes me back to the mb2 menu. Also I saw that I have this problem on servers whose address starts with 54.37.94

    Someone knows how to solve this error/issue?
     

    Attached Files:

  2. PuNk

    PuNk Internal Beta Team

    Posts:
    240
    Likes Received:
    282
    Rey banned you
     
  3. Miister_Side

    Miister_Side

    Posts:
    18
    Likes Received:
    7
  4. fortiseven

    fortiseven

    Posts:
    28
    Likes Received:
    10
  5. Puppytine

    Puppytine Slayed dreamer

    Posts:
    1,948
    Likes Received:
    1,247
    A problem that was declared as solved has returned, it seems: [SOLVED] - Can't see some servers.

    "Turns out, if I'm given completely incorrect information, and people who aren't using VPNs insist to me they're using VPNs, I reach conclusions that are wrong.

    You guys specifically are suffering from an unrelated network issue on our end affecting a small minority of players, that has nothing to do with VPN detection at all. Already working on solving it for all affected players, and in the meantime, I've just manually fixed it for the both of you. You may want to remove your IPs from a public forum post though, JKA being the way it is. Other affected players don't need to do anything else; the issue will go away on its own.


    As said, this isn't actually related to our VPN filtering at all, I concluded that because I was given untrue information while trying to figure out what was going wrong. That said, just for the record, our VPN filtering is a part of our firewall we maintain ourselves. It gets VPNs from 2 main sources:
    • Primarily: a list of known VPN IPs and datacenter IPs we maintain in-house. False positive rates for this are near-zero because all involved IPs are guaranteed to be non-residential
    • As a fallback: a set of third-party IP blacklist containing IPs that participated in Bad Things (cracking attempts, forum spam, DDoS, etc) in the previous month, since those often include many VPNs. Has a very occasional false positive mainly because of shared IPs or dynamic IPs that get reassigned.
    "

    Help us @Caelum
     
  6. Miister_Side

    Miister_Side

    Posts:
    18
    Likes Received:
    7
    I already fixed the problem. Basically, what I did was: I restarted the router and changed from Wifi to Ethernet. And now I can play in every server, that worked for me.
     
  7. Jango32

    Jango32

    Posts:
    5
    Likes Received:
    2
    Now I am having this issue on both TIN servers and the servers that start with this IP: 54.37.94. The rest are fine though.
     
  8. Caelum

    Caelum Donator

    Posts:
    16
    Likes Received:
    25
    Issue will correct itself if you encounter it, just restart your modem/router and your computer, wait a few hours, and it'll go away on its own.

    There's a whole number of reasons this sort of thing can happen, and there's kind of two issues intermingling here - getting stuck on awaiting gamestate (suggesting anti VPN false positive if you aren't using a VPN, or firewall ratelimiting on our end to filter ongoing DDoS), and getting stuck on awaiting connection (suggesting any of dozens of potential issues), which have wildly different causes - but either way, it'll resolve itself if you restart your modem/router and computer and just wait a bit. Try again tomorrow at the very latest and you should be all good.

    Purely for future reference, it'll still fix itself if you don't restart your modem/router/computer and just wait too, but it's likely to go away much faster if you do.
     
    Last edited: Jul 26, 2018
  9. Jango32

    Jango32

    Posts:
    5
    Likes Received:
    2
    I'll give it a go and wait an hour or so. To clarify, it was "Awaiting gamestate", not "Awaiting connection".

    EDIT: it works now, thanks.
     
    Last edited: Jul 26, 2018
    Caelum likes this.

Share This Page